KDevelop Error – aclocal … AM_PROG_LIBTOOL …

You got this problem while trying to compile a simple C++ file in KDevelop:

cd ‘/home/pascal/temp/atest’ && make -f Makefile.cvs && cd ‘/home/pascal/temp/atest/debug’ && CXXFLAGS=”-O0 -g3″ “/home/pascal/temp/atest/configure” –enable-debug=full && cd ‘/home/pascal/temp/atest/debug’ && make
aclocal
aclocal: configure.in: 8: macro `AM_PROG_LIBTOOL’ not found in library
make: *** [all] Error 1
*** Exited with status: 2 ***
Don’t look any further. If you are using Kubuntu, install the package libtool using adept and everything will be fine. When will compilers learn to give simple meaningful error messages??? Wasted a lot of precious time looking for that on the Internet – beware, there are many bad answers out there.

Also, using KDevelop and not being able to debug is a pain! The solution: install gdb before you start trying to debug.

6 responses to “KDevelop Error – aclocal … AM_PROG_LIBTOOL …

  1. I don’t use Kubuntu. I prefer the so-called descendants of the Red Hat clan: Fedora Core and Mandriva (I use this one).

    In this way, I don’t even waste time in downloading missing packages from the internet on MT’s verryyy slooowww ADSL (burp that’s ISDN for my 128K line).

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s