pygame on Mac: PyObjC 1.2 or later is required

Installing pygame is starightforward on Mac until you hit the above error message: PyObjc 1.2 or later is required! Solution: Install pygame 1.4

Steps to get pygame running on Leopard 10.5.4

  • Python is required; normally Mac OS X ships with python. However, if you want the latest version of python, just get it from the net (the latest version is currently 2.5.2)
  • Get the latest pygame from pygame.org (should be version 1.8.1)

This is where you should hit the above error message: PyObjc 1.2 or later is required … on trying to run pygame. However with Leopard, PyObjc 2.0 is preinstalled!!! So why doesn’t it work? I don’t know.

But the solution is not far from that: just download PyObjc 1.4 and install that and pygame start to work by magic.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s